In blog, uncategorized

If you want to install Compass Stylesheet on mac using the terminal you might encounter the following write permission. [code] gem install compass ERROR: While executing gem … (Gem::FilePermissionError) You don’t have write permissions into the /Library/Ruby/Gems/1.8 directory. [/code] The reason of the error is because you are not logged in as the root user on terminal. If you already have root use enable on your mac in terminal type (without the $) [code] $ su- [/code] If you dont have root user, you need to enable it using the following steps

  1. From the Apple menu choose System Preferences….
  2. From the View menu choose Users & Groups.
  3. Click the lock and authenticate as an administrator account.
  4. Click Login Options….
  5. Click the “Edit…” or “Join…” button at the bottom right.
  6. Click the “Open Directory Utility…” button.
  7. Click the lock in the Directory Utility window.
  8. Enter an administrator account name and password, then click OK.
  9. Choose Enable Root User from the Edit menu.
  10. Enter the root password you wish to use in both the Password and Verify fields, then click OK.

Source: http://support.apple.com/kb/ht1528 Now follow compass installation: http://compass-style.org/install/ [code] $ gem update –system $ gem install compass [/code] This should help you install Compass, which should enable foundation “Installing with Compass”

Recommended Posts
0